Suchfunktion

Aus SongBeamer Wiki

Wechseln zu: Navigation, Suche
Hilfemenü zum Programm
Info's über das Programm
Grundfunktionen von SB
Hilfe zu den Programmmenüs

(Zur bessern Übersicht werden Sie hier
auch Einträge finden, die Sie in den
Grundfunktionen finden.)
Hilfe innerhalb der Optionen
Hilfe für das Anpassen-Fenster
Plugins und nützliche Tools

In SongBeamer finden Sie eine Suchfunktion mit der sie in sekundenschnelle alle Ihre gewünschten Lieder finden.

Wie kommen Sie an diese Funktion?
  • Einfügen -> Song
  • Extras -> Song suchen...
bzw über das Tastenkürzel
  • Strg+F


Das Fenster 'Song suchen'
Das Fenster 'Song suchen'

Mit dieser Funktion können Sie in sekundenschnelle Ihren gewünschten Song finden. Alle sng-Dateien, die innerhalb des Verzeichnisses Folien bzw. in den neueren Versionen Songs abgelegt sind, werden in die Suche mit eingeschlossen.

Die Suchfunktion ist denkbar einfach: Geben Sie einfach irgendeinen Teil eines Liedes in das Suchfeld ein (zum Beispiel den Titel oder die erste Zeile des Liedes) und SongBeamersucht Ihnen alle Lieder heraus die den Suchbegriff enthalten. Dabei wird standardmäßig im Volltext durchsucht. Sie können den Suchtyp aber auch in dem Auswahlfeld, in der oberen rechten Ecke des Fensters, verändern.
Es stehen ihnen

  • "Volltextsuche" ...bei der die gesamten Dateien durchsucht werden
  • "Titel" ...bei der alle Liedtitel durchsucht werden
  • "Nur 1. Zeile" ...bei der alle ersten Zeilen aller Songs durchsucht werden
  • "Kategorien" ...bei der alle Copyrighteinträge die Sie bei Ihren Liedern haben durchsucht werden

als Suchoptionen zur Verfügung.

Die Suchtreffer mit dem Dateipfad werden in der linken Spalte angezeigt. Hier können Sie sicher schon erkennen, um welches Lied es sich handelt. Klicken Sie auf einen Liedtitel, so wird die Folie im rechten Feld angezeigt, und Sie können nun endgültig feststellen, ob es das gesuchte Lied ist. Ihre Suchtreffer werden gelb hervorgehoben.

Wenn Sie ein Lied gefunden haben und auf OK klicken wird Ihnen das Lied in der Vorschau angezeigt. Wenn Sie das Lied schon im Ablaufplan befindet wird der entsprechende Eintrag aufgerufen. Wenn Sich das Lied noch nicht im Ablaufplan befindet können Sie es über das Menü Bearbeiten -> "Zum Ablaufplan hinzufügen" in diesem aufnehmen.

  • Die Schaltfläche Hinzufügen fügt das aktuelle Lied dem Ablaufplan hinzu
  • die Schaltfläche Alle hinzufügen fügt alle gefundenen Lieder dem Ablaufplan hinzu
  • Mit OK wird das Lied aktuell geladen, ohne es in den Ablaufplan hinzuzufügen.


Einige Tipps
  • Wenn Sie nach der Suche auf Strg+Enter drücken wird der 1. Eintrag in der Liste sofort geöffnet und in Ihren Ablaufplan hinzugefügt
  • Wenn Sie die Alt-Taste gedrückt halten, während Sie auf OK klicken (bzw. Enter drücken) dann werden die einzelnen Wörter auch gefunden, wenn sie nicht nacheinander vorkommen oder ein Zeilenumbruch dazwischen ist.
  • Sie können in den Optionen einstellen in welchem Ordner gesucht werden soll. Klicken Sie dazu auf den Reiter Ordner in den Optionen.
  • Sollten in Ihren Suchergebnissen Songs doppelt auftauchen, können Sie diese direkt mit dem Tastaturkürzel STRG + ENTF löschen. Mit diesem Tastenkürzel wird die Songdatei (sng) in Ihrem Verzeichnis gelöscht.
  • Klicken Sie bei gedrückter Umschalttaste auf "Hinzufügen", um den Song direkt unter dem gerade ausgewählten Eintrag im Ablaufplan einzufügen
Persönliche Werkzeuge